Formule Excel pour convertir jj/mm/aaaa en mm/jj/aaaa

jj-mm-aaaa à mm-jj-aaaa
Table des matières

Convertir jj/mm/aaaa en mm/jj/aaaa dans Excel (avec images)

Qu’est-ce que le format de date Excel ?

Par défaut, le format de date Excel est mm/jj/aaaa. Il y a un plus grand défi à cause de ce format par défaut !

Que se passe-t-il si vous enregistrez une date au format jj/mm/aaaa 1/7/2014 (1er juillet 2014) mais qu'Excel la lira comme le 7 janvier 2014 (1/7/2014).

La première option qui me vient à l'esprit serait Clic droit > Format de cellule > Date et sélectionnez le format de date souhaité, mais cela ne fonctionnera pas ici.

Étant donné que l’option Formater les cellules modifiera uniquement le type de format de date et ne convertira pas le format de date, la meilleure façon de masquer le format de date dans Excel est d’utiliser la formule Excel mentionnée ci-dessous.

Dans cet article, nous discutons de la formule Excel qui vous aidera à convertir le format de date dans Excel de jj/mm/aaaa en mm/jj/aaaa.

Par exemple : du 7 janvier 2014 (1/7/2014) au 1er juillet 2014 (7/1/2014)

Pourquoi ?

Cette formule Excel est très utile lorsque vous disposez d’énormes données au format jj/mm/aaaa qui étaient censées être au format mm/jj/aaaa.

Comme mentionné précédemment, heureusement ou malheureusement, l'option par défaut dans Excel lit mm/jj/aaaa, donc le 1er juilletSt Excel se lit comme 7 janvierème.

Étant donné que les données sont énormes, vous ne pouvez pas les modifier une par une. Dans de tels cas, vous pouvez utiliser la formule ci-dessous !

Comment convertir jj/mm/aaaa en mm/jj/aaaa dans Excel ?

Si vous avez la date dans la cellule B1, copiez-collez la formule ci-dessous dans la cellule C1 et modifiez le format de la cellule C1 en « Date ». C'est ça!!!

				
					=SI(B1="","",SI(JOUR(B1)>12,JOUR(B1)&"/"&MOIS(B1)&"/"&ANNÉE(B1),VALEUR(DATE(ANNÉE(B1), JOUR(B1),MOIS(B1)))))
				
			

Jj/Mm/Aaaa À Mm/Jj/Aaaa

La flemme de lire ? Voir le Vidéo Youtube sur la façon de convertir jj/mm/aaaa en mm/jj/aaaa dans Excel :

Regardez comment convertir jj/mm/aaaa en mm/jj/aaaa

Faites-moi savoir à quel point cette formule a été utile ou si vous connaissez d'autres meilleures façons de convertir le format de date dans Excel de jj/mm/aaaa en mm/jj/aaaa.

Je suis sûr que vous travaillez sur de nombreuses fonctions et formules Excel, donc je Fortement Je vous recommande de suivre le cours Excel ci-dessous qui vous apprendra plus de 100 formules Excel essentielles ! C'est un investissement qui vaut la peine en vous-même ! FAIS LE MAINTENANT!

Apprenez les formules Excel avec ce cours complet vous emmenant des bases à la rédaction de formules avancées

Anson Antoine
Anson Antoine
Anson est auteur collaborateur et fondateur de www.askeygeek.com. Apprendre quelque chose de nouveau a toujours été sa passion, ASKEYGEEK.com est le résultat de sa passion pour la technologie et les affaires. Il possède une décennie d'expérience polyvalente dans l'externalisation des processus métiers, la finance et la comptabilité, les technologies de l'information, l'excellence opérationnelle et la business intelligence. Au cours de son mandat, il a travaillé pour des organisations telles que Genpact, Hewlett Packard, M*Modal et Capgemini dans divers rôles et responsabilités. En dehors des affaires et de la technologie, c'est un cinéphile qui passe des heures ensemble à regarder et à apprendre le cinéma et un cinéaste aussi !

11 réponses

  1. Merci pour l'info.

    Je suis coincé avec l'erreur ci-dessous lors de l'utilisation de cette formule. J'essaie de convertir les dates ci-dessous, mais j'obtiens l'erreur #Name
    J'ai également besoin d'un horodatage dans la colonne convertie

    21/05/2021 11:30:33 convertir en 21/5/2021 11:30:33,
    Pouvez-vous s'il vous plaît m'aider à ce sujet ?

    1. Salut Vijay,

      Merci de me l'avoir fait savoir !

      Vous pouvez utiliser la formule ci-dessous pour convertir les dates en jj/mm/aaaa en mm/jj/aaaa même si le jour est supérieur à 13.

      =SI(B1=””,””,SI(JOUR(B1)>12,JOUR(B1)
      &”/”&MOIS(B1)&
      "/"&ANNÉE(B1),VALEUR(DATE(ANNÉE(B1),
      JOUR(B1),MOIS(B1)))))

      J'ai mis à jour la formule dans le post !!

      Merci,
      Anson

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Toutes nos félicitations!
Tu l'as fait,
Ne fermez pas !
Saisissez votre chance de gagner 100 000 crédits de personnage UberTTS
Merci pour votre visite!

Cette fenêtre contextuelle ne montrera pas à toi de voir encore!!!

L'œuf de Pâques UberTTS 100K
Share to...